Versão 4.15 do Linux traz primeiras correções para Meltdown e Spectre

A versão 4.15 do kernel Linux foi liberada com as primeiras correções para as vulnerabilidades Meltdown e Spectre. Segundo o desenvolvedor primário do sistema operacional livre, porém, ainda estamos longe de uma solução final para o problema.

"Enquanto o Spectre e o Meltdown obviamente foram a grande notícia neste ciclo de lançamentos, é válido notar que nós obviamente tivemos todos os updates 'normais' rolando também, e todo o trabalho em todos os outros lugares não parou de maneira mágica, mesmo que alguns desenvolvedores tenham ficado distraídos por problemas nas CPUs. No quadro 'geral', 4.15 parece perfeitamente normal, com dois terços de todo o patch 4.15 sendo sobre drivers... e não mitigação de bugs de CPU".
- Linus Torvalds, criador primário do Linux

Assim como os desenvolvedores de outros sistemas operacionais, Torvalds está aguardando os designers de hardware da Intel completarem os seus patches de microcódigo e o firmware de seus processadores.

Mas isso tudo ficará para versões futuras do kernel. Para o update 4.16, o ciclo de desenvolvimento voltará a focar em implementações mais triviais. "Com sorte, nós vamos ter um ciclo de lançamento 'normal' e inteiramente chato para o 4.16. Porque chato é muito bom", completa Linus Torvalds.

.....

Está pensando em comprar algum produto online? Conheça a extensão Economize do Adrenaline para Google Chrome. Ela é gratuita e oferece a você comparativo de preços nas principais lojas e cupons para você comprar sempre com o melhor preço. Baixe agora.

Via: LKML, ZDNet
Tags
  • Redator: Carlos Felipe Estrella

    Carlos Felipe Estrella

    Apaixonado por games desde os 6 anos de idade, quando ganhou um Playstation 1. Em 2005 migrou para o PC, e aí começou a se interessar por tecnologia. Formado jornalismo na Universidade Federal de Santa Catarina.

O que você achou deste conteúdo? Deixe seu comentário abaixo e interaja com nossa equipe. Caso queira sugerir alguma pauta, entre em contato através deste formulário.